EGEsoll - сборник решений задач из ЕГЭ

Задача 9 администратор

Системный администратор раз в неделю создаёт архив пользовательских файлов. Однако объём диска, куда он помещает архив, может быть меньше, чем суммарный объём архивируемых файлов. Известно, какой объём занимает файл каждого пользователя.

По заданной информации об объёме файлов пользователей и свободном объёме на архивном диске определите максимальное число пользователей, чьи файлы можно сохранить в архиве, а также максимальный размер имеющегося файла, который может быть сохранён в архиве, при условии, что сохранены файлы максимально возможного числа пользователей.

В первой строке входного файла находятся два числа: S  — размер свободного места на диске (натуральное число, не превышающее 10 000) и N  — количество пользователей (натуральное число, не превышающее 3000). В следующих N строках находятся значения объёмов файлов каждого пользователя (все числа натуральные, не превышающие 100), каждое в отдельной строке.

Запишите в ответе два числа: сначала наибольшее число пользователей, чьи файлы могут быть помещены в архив, затем максимальный размер имеющегося файла, который может быть сохранён в архиве, при условии, что сохранены файлы максимально возможного числа пользователей.

Download File 1

Добавлено: 08.05.26 13:13

Перейти к решению

Решение

Решение на Python:

f = open("embed.txt")
S, N = list(map(int, f.readline().split()))
files = sorted([int(l) for l in f.readlines()])
added = []
while S - files[0] >= 0:
    n = files.pop(0)
    added.append(n)
    S -= n
print(len(added), max(added)) # 149, 7

Ответ: 149 7

Автор - rubygem17

Объяснение

None

Назад